LollipopKingdom

Crashes when putting in bank pin

Recommended Posts



iDzn   

I'll add this here as I assume it'll be a related issue.

 

During my testing for tutorial island, in order to create an ironman you must set a bank pin, as soon as the bank pin screen loads up, exactly as op says, the script just stops. There is no log, no error no nothing just simply stops.

 

Java version: 

openjdk version "1.8.0_212"

OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_212-b04)

OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.212-b04, mixed mode)

RSBot version: 7114

Game version: OSRS

Operating System: macOS Mojave 10.14.5

 

RSBot Log: Nothing prints into the log, just shuts the script off.

RSBot Settings: I tried with and without adding a pin.

Script used: TutorialIsland Free but feature isn't online yet but simply it clicks the set pin widget then just opens the interface and dies.

Edited by iDzn

Share this post


Link to post
Coma   
8 hours ago, iDzn said:

final String pin = ctx.getPin();
		if (pin == null) {
			ctx.controller.stop();
			return;
		}

https://github.com/powerbot/RSBot-API/blob/master/src/main/java/org/powerbot/bot/rt4/BankPin.java

 

ctx.getPin() returns null even if I supply it with a pin to which I assume is the problem.

Open an issue on Github and we'll get to it.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...