Sign in to follow this  
ZolloKaptain

Error setting up script

Recommended Posts

Java Version: 1.8.0_211

Game Version: Old School

Operating System: Windows 10

 

RSBot Log: N/A, cant get that far

RSBot Settings: N/A, cant get that far

Script Used: N/A, can't get that far

 

Hi, I followed the directions of this video here: 

 

Description: I've been struggling with this for a while, I cannot see what I am doing wrong. I'm 99% certain that the issue I have is regarding the javaapplet config because when I run without it, the launcher comes up albeit without the menu bar which I greatly need. However, I'll start from the beginning. I installed IntelliJ, created a new project setting the location to the RsBot folder that I created on my desktop that contained RSBot-7109.jar. Then, I went to project structure changed the programming level to 6, linked RSBot-7109.jar in the library, and changed the compiler path setting to 'use module compile output path' while also shortening the output path and test output path.

 

After this, I went to the configuration adding a jar application with these settings.

 

Path to JAR: C:\Users\stone\jagexcache\jagexlauncher\bin\jagexappletviewer.jar

VM Options: -Djava.search.path=out -Dcom.jagex.config=http://oldschool.runescape.com/l=en/jav_config.ws -javaagent:"C:\Users\stone\Desktop\RsBot\RSBot-7109.jar"

Program arguments: runescape

Working Directory: C:\Users\stone\Desktop\RsBot

 

After this, I changed the JRE to the 32-bit version.

 

After running, I got these errors:

Error occurred during initialization of VM
Failed to find Premain-Class manifest attribute in C:\Users\stone\Desktop\RsBot\RSBot-7109.jar
agent library failed to init: instrument

 

I hope this was thorough enough.

Would appreciate any help! Thank you!

Share this post


Link to post
Eldorado RuneScape Gold

Hey Chris, sorry to bother you --I'm sure you're a very busy man-- but I was wondering if you might know why my script is not working for RSBot. I followed your second tutorial to the dot, looked over each of your classes to made sure I had it down exactly -- did this because I decided to write my own code before I watched your second vid and was getting a weird error -- and when I run RSBot through IntelliJ and click File -> Start -> (Mining Script), nothing happens. It's also strange because I set up a little print statement in the poll method to see if it was even accessing that method and found out that it was, was getting a "Running" message ever so often as I assumed it looped through poll().

 

I've linked file structure, on the left of each screenshot, and code.

My Miner class is your QuickMining class, I named it badly I know.

 

Any help would be greatly appreciated! Thanks!

https://www.dropbox.com/sh/jwpndluqjjtkzah/AADa7yqyMmg_cyTVmr5X_grGa?dl=0

 

Share this post


Link to post

Alright, not sure why I didn't think of that in the first place. But, I placed print statements to notify me at basically every step, and from that I've gathered, much to my confusion, that it reads through the entire execute method, and all other's for that matter. I had two print statements placed at the beginning and end of the execute method, and they were both printing. So, just to try, later I put print statements after every line of code in the execute method, and each of them were printing. 

 

Also, just like before my player is doing nothing. I decided to turn on mouse and print trails and noticed that the mouse was "stuck" in the top left corner of the client.

https://www.dropbox.com/sh/jwpndluqjjtkzah/AADa7yqyMmg_cyTVmr5X_grGa?dl=0

Another screenshot added.

 

UPDATE: This is just some more info here, but I decided to run the debugger and when the program reaches the statement where the GameObject is initialized it gives me this:

"org.powerbot.script.rt4.GameObject[id = -1, name=, type=UNKNOWN,tile = (-1, -1, -1)]

 

It seems like ID here should be referring to the rock id that I passed as an argument to the id method. I tried manually putting an ID that I know is correct, and the statement above still shows when running the debugger,.I'm not sure if this really helps but I'm just trying to provide as much information as I can.

Edited by ZolloKaptain

Share this post


Link to post
Sign in to follow this