Sign in to follow this  
N0N3

Play button doesn't work properly on Linux

Recommended Posts

N0N3   
Java version: Visible within the post
RSBot version: 7107
Game version: Old School
Operating System: Debian 9 & Ubuntu 16.04 / 18.04
Exception: 
java.lang.NullPointerException
	at org.powerbot.gui.BotPreferences.<init>(BotPreferences.java:52)
	at org.powerbot.gui.BotMenu$1.done(BotMenu.java:308)
	at javax.swing.SwingWorker$5.run(SwingWorker.java:737)
	at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(SwingWorker.java:832)
	at sun.swing.AccumulativeRunnable.run(AccumulativeRunnable.java:112)
	at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(SwingWorker.java:842)
	at javax.swing.Timer.fireActionPerformed(Timer.java:313)
	at javax.swing.Timer$DoPostEvent.run(Timer.java:245)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Terminal error when pressing "Play" to open scripts menu.

 

java version "12.0.2" 2019-07-16
Java(TM) SE Runtime Environment (build 12.0.2+10)
Java HotSpot(TM) 64-Bit Server VM (build 12.0.2+10, mixed mode, sharing)

Tried with OpenJDK 1.8. and manually installed Java 12.0.2.

 

On Debian 9 the transparent window will be black and game doesn't show up, but you can see it by dragging the window until you release the dragging the transparent window jumps back on its position. On Debian the "Play" button works just fine it shows up as basic Java layout (the ugly one) but transparent(black window) problem makes it "unplayable", because I cannot monitor what bot does and login is difficulty.

 

On Ubuntu 16.04/18.04 the transparent window works just fine, it doesn't hide the game as it works properly, but menu remains still black as it is on Debian too. "Play" button still have same error.

 

I noticed that the choosing a game works from menu, but "Play" button is totally fucked up on my workstations.

 

 

Share this post


Link to post


Sign in to follow this