Sign in to follow this  
epaulz

IntelliJ "Failed to find Premain-Class manifest" in .jar after update to 7097

Recommended Posts

epaulz   

My script was working beautifully yesterday but this morning I downloaded the update and reconfigured and now I'm getting the following error from my IDE:

 

"C:\Program Files (x86)\Java\jre1.8.0_211\bin\java.exe" -Djava.search.path=out -Dcom.jagex.config=http://oldschool.runescape.com/l=en/jav_config.ws -javaagent:C:\Users\foo\RSBot\RSBot-7097.jar -Dfile.encoding=windows-1252 -jar C:\Users\foo\jagexcache\jagexlauncher\bin\jagexappletviewer.jar runescape
Error occurred during initialization of VM
agent library failed to init: instrument
Failed to find Premain-Class manifest attribute in C:\Users\epaulz\RSBot\RSBot-7097.jar

Process finished with exit code 1

 

Everything builds fine but I can't run the applet.  I tried to find related topics on the forums so I wouldn't repeat a question but couldn't come up with anything.  Apparently the manifest file is read-only?  I'm an experienced programmer but don't work with Java at all other than for rsbot.  Any thoughts?  Can I revert back to an older version?

 

Thanks

 

Edit: Sorry, just read the sticky post on formatting.

Java version: 1.8.0_211

Game version: OSRS

OS: Windows 10

Reproduce: update to RSBot-7097.jar, edit project structure and configuration to use new jar, rebuild everything, run, observe error message in run output

Edited by epaulz
Didn't read sticky post about formatting before posting, sorry!

Share this post


Link to post


epaulz   

I got past this issue.  Seems like there are some updated parameter settings with the new patches (found here) like no longer needing a javaagent option.

 

I got the applet running, but now I'm missing my toolbar to run scripts etc.  The thread I linked to seems to indicate this was a bad patch so we might just have to wait for a fix 😞

Share this post


Link to post
Sign in to follow this