Jump to content
RSGoldMine RuneScape Gold RuneScapeGoldMarkt RuneScape Gold OSRS Gold Probemas RuneChat RuneScape Games to win Coins and Gold

[PREMIUM] ACrafting OS - Complete crafting script. Supports all items at many different locations


Recommended Posts



Complete crafting script, supporting virtually every item in the game.

Featuring an item queue, you are able to create your own path to skill mastery!

The script also contains advanced antipatterns to provide fast and as safe as possible leveling.

Get the script on the Store.




  • Leather, Hardleather, Snakeskin, Yak-hide, all Dhide colors


  • Leather, Hard Leather, Snakeskin, Green Dragon Leather, Blue Dragon Leather, Red Dragon Leather, Black Dragon Leather


  • Beer glass, Candle lantern, Oil lamp(empty), Vial, Fishbowl, Unpowered orb, Lantern lens, Empty light orb, Molten glass (furnace only)


  • Air, Earth, Water, Fire


  • Silver: Opal, Jade, and Topaz Jewellery, Unstrung symbol, Unstrung emblem, Silver sickle, Silver bolts, Tiara
  • Gold: Ring, Necklace, Bracelet, Amulet
  • Gem: Sapphire, Emerald, Ruby, Diamond, Dragonstone, Onyx

Gem Cutting

  • Opal, Jade, Topaz, Sapphire, Emerald, Ruby, Diamond, Dragonstone, Onyx


  • Forms and fires pottery in one run
  • Pot, Pie dish, Bowl, Plant pot, Pot lid


  • Ball of wool, Bow string, Magic string, Rope


  • Supports usage of Super/Normal Energy and Stamina potions.

Supported Banks

  • Pottery:  Crafting Guild, Barbarian Village
  • Spinning: Crafting Guild, Seers' Village, Lumbridge castle, Barbarian Village
  • Jewellery: Edgeville, Al'Kharid, Port Phasmatys, Neitiznot
  • Tanning: Crafting Guild, Al'Kharid
  • Other: Any bank











Edited by Artificial




Link to post
  • Replies 881
  • Created
  • Last Reply

Top Posters In This Topic

Hey man ive been trying to craft emerald rings, script starts up and goes to bank. When it opens the bank it withdraws a full inventory of gold bars and never any emeralds. This happens at both port p and at edgeville, cant get the script to go beyond this step. So it looks like banking is messed up. I also have it set so it should withdraw 13 of each but still just goes to a whole inventory. Hope this helps! If not shoot me a pm

Link to post

When it tires to craft leather gloves it deposits the thread into the bank, and only takes out a needle and leather. Then closes bank and uses needle with leather, then gets the message you need some thread. 


Why does it deposit the thread if i need thread to craft the gloves?? ..

Link to post

I'm not sure if this has already been addressed but i couldn't get molton glass to work. I started in al kharid with 14 ash and 14 sand, it recongized what it has to do, but when it reached the furance it attempted to smelt by clicking on the furnace (this only gives bar options) rather than clicking on a sand bucket then the furance ( gives molton glass options). If i was just doing something wrong let me know thanks for the help :)

Link to post

Currently making Gold Bars -> Gold Amulet (u) and the walking to and from the furnace is fine. 


Removing the gold bars from the bank is fine.


Once I reach the furnace, the gold bar is clicked, and then it doesn't continue from there on. It doesn't click on the furnace to select making the Gold Amulet (u).


It just sits in the room, and doesn't begin making the amulet.



It works for a few inventories, but then what I explained above happens ^^^


I think the problem is that it doesn't click from the bar, to the furnace, or that it is using the gold bar with the people standing at the furnace smelting, and "nothing interesting happens"

Link to post

i have qued up multiple bow string actions, with a value of 28. and then selected i am in luby castle. and nothing happens after clicking start. tried starting at the bank(with strings in bag, and then again with nothing, and again with flax) and also tried the exact same method at the spinning wheel. the script seems to be broken, or outdated

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...