RSGoldMine RuneScape Gold RuneScapeGoldMarkt RuneScape Gold OSRS Gold Probemas RuneChat RuneScape Games to win Coins and Gold
Sign in to follow this  
Chris

How do I open, and use, RSBot? **RSBOT 8.1 UPDATE**

Recommended Posts

Chris   

Requirements:

  • NONE

 

That's right! As of RSBot 8.1 there are no requirements to run RSBot, everything is now included. Wow. As a user of RSBot you should download the correct client for your system.

 

If you're on Microsoft Windows, you need our Windows client. If you're on Mac OSX, you need our Mac client

 

The observant among you may also notice there is a "Universal" client, this is for developer use ONLY. If you're a developer wishing to use the Universal client, you need AdoptOpenJDK 11 installed, and use this to run RSBot.

 

 

Having troubles?

  • If you're on Windows, try running as Administration (Right Click -> Run as administrator).
  • If you're on Mac, right click and Open.

Share this post


Link to post
Chris   

How to add scripts to RSBot?
 
Requirements:

 

[hr] 
There is just one thing to note when adding scripts, which is the game type that you are looking at. If you want to bot on OSRS then you will need to select OS, otherwise select RS3 for RS3 and DarkScape scripts.

  • Click the game type at the top (RS3 | OS)
  • Click the 'add' button next to the script you want to use

 

[hr] 
Can't add scripts?
Not to worry. Make sure you sign in (top right of the page), if it logs you out again automatically follow these steps

  • Login

If the issue persists you should use a different web browser, we like to recommend FireFox.

Share this post


Link to post
Mooshe   

Hi, I have downloaded rsbot and 'added a script'. Each time I click on rsbot it takes me straight to the new one instead of the old. How do I change this so it goes to the old school? Also once in game how do I use a script? I'm a noob at this so any help is appreciated. Thanks.

 

1. Create a new text document in the same folder which has your RSBot file.

 

2. Copy + paste this:

@ECHO OFF
java -Dcom.jagex.config=http://oldschool.runescape.com/l=en/jav_config.ws -jar RSBot.jar
exit

3. Save as "RSBot OS.bat", with "All (*)" file extension selected.

 

 

4. Rename RSBot-7020.jar to RSBot.jar

 

5. Double-click RSBot OS.bat

Share this post


Link to post

1. Create a new text document in the same folder which has your RSBot file.

 

2. Copy + paste this:

@ECHO OFF
java -Dcom.jagex.config=http://oldschool.runescape.com/l=en/jav_config.ws -jar RSBot.jar
exit

3. Save as "RSBot OS.bat", with "All (*)" file extension selected.

 

 

4. Rename RSBot-7020.jar to RSBot.jar

 

5. Double-click RSBot OS.bat

thank you very much for your speedy response. I will get straight to this.

 

Edit: As I am on mac I do not have the option to select the file extension as "All*". Is RTF okay or not?

Edited by roflmerchant

Share this post


Link to post
Mooshe   

thank you very much for your speedy response. I will get straight to this.

 

Edit: As I am on mac I do not have the option to select the file extension as "All*". Is RTF okay or not?

 

ah, then for a mac it's different. You can launch it from the terminal.
 

1. Move RSBot.jar to your desktop

 

2. Press ⌘ + Space

 

3. In finder, type "Terminal", and open up the terminal

 

4. When the terminal pops up, type cd ~/Desktop/

 

5. Now type this:

java -Dcom.jagex.config=http://oldschool.runescape.com/l=en/jav_config.ws -jar RSBot.jar

Share this post


Link to post

I have not been able to run the client since making my account. whenever i got to (script) and click (play) the login menu appears. i type in my account name and password and it always says incorrect. I have tried both acct name and email but neither work. Does my account need some sort of verification before i run my scripts? Also when i click (get Pin) i gecieve the pin and type it in but the button still says (get pin) not login

 

 

Thanks

-Wes

Share this post


Link to post
Chris   

I have not been able to run the client since making my account. whenever i got to (script) and click (play) the login menu appears. i type in my account name and password and it always says incorrect. I have tried both acct name and email but neither work. Does my account need some sort of verification before i run my scripts? Also when i click (get Pin) i gecieve the pin and type it in but the button still says (get pin) not login

 

 

Thanks

-Wes

the pin is instead of your password

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this