Sign in to follow this  
Coma

Botting in high definition OpenGL

Recommended Posts

How do you get out of safe mode? 
4GnkX.png

  

Same

I have always had to restart my comp to fix that issue. Seems like havs an onboard GPU as well as onboard graphics creates this problem sometimes.

Share this post


Link to post
Lawdy   

I have always had to restart my comp to fix that issue. Seems like havs an onboard GPU as well as onboard graphics creates this problem sometimes.


I see, I'll try again when I get home from school.

Share this post


Link to post
NKN   

When I had entering OpenGL issues, I did this.

 

Close RSBot, and any running instances of the games.

 

Open a new browser, load RuneScape fully.  Pop it into OGL mode.

 

Close the browser down fully, open RSBot, viola in OGL mode.

 

 

if it didn't work, delete the caches and repeat the above steps. :s

Share this post


Link to post

of course it's available now

Can't wait for Direct X as that is the best if you have a good GPU in your computer. Congrats on OpenGL release. [member=voltaire] said something about Direct X being easier to code after you have implemented OpenGL, is that true?

Edited by Spartan 117

Share this post


Link to post
Draknyte   

For me, neither does OpenGl. Do i have to install something for OpenGl? Because it works on the download client and website aswell :\. It just dosent work on powerbot. I dunno why lol
 
Edit: I tested it and this is what i have... Could this be it?
 
"OpenGL 2.1 (Intel(R) HD Graphics with 112 ext.)"
 
Oh and do you know if DirectX will be supported any time soon, because that runs smoother in my opinion to OpenGl. Might just be my computer

It's windows only, so it benefits less people compared to OpenGL.
However the performance gains over OpenGL are noticeable.
 
 

Can't wait for Direct X as that is the best if you have a good GPU in your computer. Congrats on OpenGL release. [member=voltaire] said something about Direct X being easier to code after you have implemented OpenGL, is that true?

I'd imagine it was just due to priorities.

Share this post


Link to post

It's windows only, so it benefits less people compared to OpenGL.
However the performance gains over OpenGL are noticeable.
 
 
I'd imagine it was just due to priorities.

Also cuz he does all his coding on a mac, which does not support direct X.

Share this post


Link to post
Draknyte   

Also cuz he does all his coding on a mac, which does not support direct X.

You've only repeated my point on priorities. Simply put:
OpenGL is cross platform & benefits more users.
DirectX is Windows only (mostly), but that's not a real excuse for [member=Voltaire] not to develop it.

Share this post


Link to post
Algol   

You have to run the client with JRE, not JDK. That's why you have an error.


Works :) Edited by Algol

Share this post


Link to post
Lawdy   

Can't get it working.
 
Stacktrace:

[spoiler]Error: client.init sun.reflect.NativeMethodAccessorImpl.invoke0 sun.reflect.NativeMethodAccessorImpl.invoke:57 sun.reflect.DelegatingMethodAccessorImpl.invoke:43 java.lang.reflect.Method.invoke:606 Rs2Applet.a Rs2Applet.init org.powerbot.bot.Bot.super org.powerbot.bot.Bot.super org.powerbot.bot.AuX.run org.powerbot.bot.loader.NRSLoader.run java.lang.Thread.run:724 | java.lang.RuntimeException | 

ajc
at py.i(py.java:136)
at py.l(py.java:105)
at abh.<init>(Unknown Source)
at ca.l(ca.java:13)
at dt.e(Unknown Source)
at yf.l(yf.java:50)
at uo.fq(uo.java:1919)
at zh.fp(zh.java:1879)
at tq.fc(tq.java:1872)
at rp.ani(rp.java:11270)
at dm.k(dm.java:516)
at x.i(x.java:351)
at rp.d(rp.java:255)
at yh.s(yh.java:193)
at client.gj(Unknown Source)
at client.au(Unknown Source)
at pg.w(pg.java:584)
at pg.j(pg.java:560)
at pg.run(pg.java:517)

at java.lang.Thread.run(Thread.java:724)[/spoiler]

Share this post


Link to post

Can't get it working.
 
Stacktrace:

[spoiler]Error: client.init sun.reflect.NativeMethodAccessorImpl.invoke0 sun.reflect.NativeMethodAccessorImpl.invoke:57 sun.reflect.DelegatingMethodAccessorImpl.invoke:43 java.lang.reflect.Method.invoke:606 Rs2Applet.a Rs2Applet.init org.powerbot.bot.Bot.super org.powerbot.bot.Bot.super org.powerbot.bot.AuX.run org.powerbot.bot.loader.NRSLoader.run java.lang.Thread.run:724 | java.lang.RuntimeException | 

ajc
at py.i(py.java:136)
at py.l(py.java:105)
at abh.<init>(Unknown Source)
at ca.l(ca.java:13)
at dt.e(Unknown Source)
at yf.l(yf.java:50)
at uo.fq(uo.java:1919)
at zh.fp(zh.java:1879)
at tq.fc(tq.java:1872)
at rp.ani(rp.java:11270)
at dm.k(dm.java:516)
at x.i(x.java:351)
at rp.d(rp.java:255)
at yh.s(yh.java:193)
at client.gj(Unknown Source)
at client.au(Unknown Source)
at pg.w(pg.java:584)
at pg.j(pg.java:560)
at pg.run(pg.java:517)

at java.lang.Thread.run(Thread.java:724)[/spoiler]

Many people are reporting the same thing in bot support

Share this post


Link to post
Timer   
You have to run the client with JRE, not JDK. That's why you have an error.

Share this post


Link to post
Piers   

Hey Timer/Paris,

 

is it possible to get OGL working with JDK? Is that something that is in line to be worked on?

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this