Shuruki

[OSRS] Shu's Gilded Altar | Fast Prayer Experience

Recommended Posts

Shuruki   

Shu's Gilded Altar

Old School Runescape

Currently on SDN

Description

  • The script will Un-note bones with Phial at Rimmington and search for a host. Once a host is found, it'll use the Gilded Altar inside the host's house for great prayer experience.

Future Plans

  • No future plans as of right now, there is a premium version with extra features. If you want more features feel free to buy that version.
  • I will only continue to only maintain, optimize, and add more antiban ideas in the script.

Features

  • All Bones Supported
  • Will find Host for you
  • Antiban

Requirements

  • Gold Coin Stack and Desired Noted Bones to Pray in Inventory.

Instructions

  • Start at Rimmington between Portal and Phial.
  • World 330

Recommendations

  • World 330
  • Do not bot more than 2 hours consecutively. The script does have an Antiban but there is still a chance to get banned.

If the script randomly stopped

Check View>Log to check if the script terminated itself.

 

Edited by Shuruki

Share this post


Link to post


iDzn   

Figured I'd check out the competition, I'm not a dick so figured I'd let you know the bugs I found.

  1. Sat spamming bones on players rather than using them on the altar, let it do it 7 times before I manually intervened to use them on the altar for it.
  2. While praying, constantly clicking on the bones in my inventory, pretty sure at one point it manually buried a bone through the spamming.
  3. Because of #2 it gets stuck on "Use Bone" when the bone is no longer valid in the inventory thus can't do any other actions, watched it try to open different tabs and couldn't open the portal either.
  4. Uses noted bones on players rather than phials, doing this causes you to follow a player till you get within distance and it says "Nothing interesting happens" I almost followed a guy to Falador before I intervened again.
  5. Not a biggie but took quite a while for it to exchange the bones once it had finally interacted with phials and the chat interfaces were there.

If it makes you feel better, all stuff I encountered in the early stages of my script 🙂

 

Hope it helps!

Share this post


Link to post
Shuruki   
4 hours ago, iDzn said:

Figured I'd check out the competition, I'm not a dick so figured I'd let you know the bugs I found.

  1. Sat spamming bones on players rather than using them on the altar, let it do it 7 times before I manually intervened to use them on the altar for it.
  2. While praying, constantly clicking on the bones in my inventory, pretty sure at one point it manually buried a bone through the spamming.
  3. Because of #2 it gets stuck on "Use Bone" when the bone is no longer valid in the inventory thus can't do any other actions, watched it try to open different tabs and couldn't open the portal either.
  4. Uses noted bones on players rather than phials, doing this causes you to follow a player till you get within distance and it says "Nothing interesting happens" I almost followed a guy to Falador before I intervened again.
  5. Not a biggie but took quite a while for it to exchange the bones once it had finally interacted with phials and the chat interfaces were there.

If it makes you feel better, all stuff I encountered in the early stages of my script 🙂

 

Hope it helps!

 

That's really weird. All those things shouldn't be happening because I made sure I fixed them before released. I''ll need to double check it running it from Rsbot not from IDE.

1.  Shouldn't happen because I made the .Interact("Use","Altar") I could see some misclicks but 7 times is insane.

2. I have a Lambda Condition wait to break only until bones are empty or I level up. So that is awkward.

3.  I'm a little confused on this one. So when there aren't any noted? or unnoted bones?

4. LOL that is funny, you almost went to Falador? Same with #1 I made it specifically interact with Phial. So I can see some misclicks from the client but following a guy is crazy. I'll double check that

5. Yea, it's slow sometimes but other times it goes instantly. So I left it alone, which could provide a little randomness.

 

Thanks for the help but I'm literally shocked these bugs are still in. Pretty positive I fixed them but I'll double check em.

Share this post


Link to post
iDzn   
8 minutes ago, Shuruki said:

 

That's really weird. All those things shouldn't be happening because I made sure I fixed them before released. I''ll need to double check it running it from Rsbot not from IDE.

1.  Shouldn't happen because I made the .Interact("Use","Altar") I could see some misclicks but 7 times is insane.

2. I have a Lambda Condition wait to break only until bones are empty or I level up. So that is awkward.

3.  I'm a little confused on this one. So when there aren't any noted? or unnoted bones?

4. LOL that is funny, you almost went to Falador? Same with #1 I made it specifically interact with Phial. So I can see some misclicks from the client but following a guy is crazy. I'll double check that

5. Yea, it's slow sometimes but other times it goes instantly. So I left it alone, which could provide a little randomness.

 

Thanks for the help but I'm literally shocked these bugs are still in. Pretty positive I fixed them but I'll double check em.

1. Before the interaction, it may well say “Altar” but before the actual click due to the amount of moving players before the actual click it doesn’t select altar. To be fair it didn’t even right click to go through the menu just kept left clicking. I solved this by bounding a smaller area on the back of the altar.

 

2. It waited for about 5-7 bones then just went crazy.

 

3. So what happens is it tries to select an unnoted bone to use it on the altar but when it selects it, it then gets buried as the altar auto burries so the selected item is gone from the inventory but the menu in the top left remains the same Use xBone -> Portal for example, then because it’s trying to find leave -> portal but it can’t “leave” because it has an old item selected.

 

4. The guy I used it on ran past the portal to tally so I quickly had to allow input to stop it running away haha.

Share this post


Link to post
Shuruki   
18 minutes ago, iDzn said:

1. Before the interaction, it may well say “Altar” but before the actual click due to the amount of moving players before the actual click it doesn’t select altar. To be fair it didn’t even right click to go through the menu just kept left clicking. I solved this by bounding a smaller area on the back of the altar.

 

2. It waited for about 5-7 bones then just went crazy.

 

3. So what happens is it tries to select an unnoted bone to use it on the altar but when it selects it, it then gets buried as the altar auto burries so the selected item is gone from the inventory but the menu in the top left remains the same Use xBone -> Portal for example, then because it’s trying to find leave -> portal but it can’t “leave” because it has an old item selected.

 

4. The guy I used it on ran past the portal to tally so I quickly had to allow input to stop it running away haha.

 

1. Yea, I noticed that even though I have an "Interact()" the Client just clicks. I just assumed that it had no other object/player on top of it, so there was nothing conflicting with "Use" "Altar", so there was no need to right click.

 

2. Did you level up by any chance? I literally have no idea whats wrong with this issue. I'ma just put it on the back burner and see if anyone reports that.

 

3. Oh, I see what you mean. Is it because of Issue #2? because I never really had that happen to me. I'll pay close attention next time.

 

4. Oh man, that was unlucky. I assumed a couple misclicks can occur but that is crazy haha. I can put a failsafe once the player leaves the area it'll stop the script or return.

 

So I'm currently running the script for a total of 40 mins right now and no issue. I'm using normal bones though, could be that it goes full retard with other bones.

Share this post


Link to post
Shuruki   

Update:

  • Fixed a problem where the script would get stuck using Fixed Mode.
  • Added several conditions where the script could potentially get stuck or reduce efficiency.
  • Added more detailed information being written to Log for debugging.
Edited by Shuruki

Share this post


Link to post
Shuruki   

Update:

  • Added failsafes to the script. Script will terminate if certain conditions don't happen.
  • Script will terminate after 4 attempts of typing incorrect Hosts.
  • Tweaked with the Antiban.

View>Log will show if the script terminated itself.

Edited by Shuruki

Share this post


Link to post
Shuruki   
39 minutes ago, Zorichy said:

Used this last week, works really well 👊🏼

 

Glad to hear it worked well. Thanks

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now