needscroll

[FREE][RS3] FreeRunecrafter

Recommended Posts

Hello again.

While browsing the scripts I realized there is no free runecrafting script.

So I made one!

(I know there is a paid one. This script supports only nonmember runes to avoid competition. My script is meant for people who only want to do a little light runecrafting without heavy investment. If you want to craft blood runes for massive moneymaking you should use the paid script)

 

NOTE: For best effects, use in fullscreen mode.

 

Features

-Crafts all nonmember runes at the respective alters

-dynamic walking

-Antiban

 

Banks to use with alters

-Air == Varrock West Bank

-Water == Draynor Bank

-Earth == Varrock East Bank

-Fire == Duel Arena Bank

-Body == Edgeville Bank

-Mind == Falador West Bank

 

To use, start off in the bank listed with the alter above with the right tiara. See images.

 

Some Images

K1Agkqa.png

ljZb95X.png

Edited by needscroll

Share this post


Link to post


-deleted-

 

(didn't know that pure ess was so cheap these days!)

Edited by JoshAtWar
complained about something to then realise I was wrong (..!)

Share this post


Link to post

Got it to work as far as the rune altar  -  once it gets there, the load screen resets the tilt of the screen and the script is utterly out of its depth. It just rotates around looking for the altar but never finds it. Really sad, and props to the writer for trying, but this script is not fit for purpose.

Share this post


Link to post
7 hours ago, JoshAtWar said:

sorry but since this doesn't work with normal essence it's a complete waste of space. only a lunatic would use pure ess to make mind runes 

 

7 hours ago, JoshAtWar said:

I tried it anyway and it "pure" does not work. Wasted me a tonne of money swapping rune ess for pure.

 

 

Pure essence currently costs less than rune essence and does the same thing which is why I choose it.

However, I can add an option for rune essence if you would like me to do so.

 

6 hours ago, JoshAtWar said:

Got it to work as far as the rune altar  -  once it gets there, the load screen resets the tilt of the screen and the script is utterly out of its depth. It just rotates around looking for the altar but never finds it. Really sad, and props to the writer for trying, but this script is not fit for purpose.

Which alter / rune are you trying to craft?

Are you running in fixed mode or full screen?

If possible, can you post an image of the problem?

I will do some testing to see if I can fix the bug.

Edited by needscroll

Share this post


Link to post

Hey, I'm sorry for having a go at your script earlier. It's not like you're getting paid for this and it can't be nice writing and working on something for people to then just be as ungrateful as me! I had my reasons for being short tempered but knowing them will do you no good.

 

I have stuck with the script and what has really helped me is locking my screen on maximum zoom via the options -> controls screen. It still gets stuck though. The fire altar is almost perfect, almost never getting stuck, but the mind and air altars get stuck about 25% of the time- it's just because when the screen loads sometimes, the altar isn't in view. There's also sometimes a problem getting back out of the ruins  - sometimes the character walks away from the exit and if it does that, there's not much chance of it finding it's way back.

I think a good fix (though I'm not at all a programmer) would be to click ON the altar itself to move the character closer in between entering the ruins and crafting the runes. That way the altar is sure to be on screen. It might also work in reverse to fix the issue with it getting stuck on the way out of the ruins.

 

So far, I've used the script to craft over 5k runes and get my rc up 35 levels, so it can't be said that the script doesn't work, however, I've had to keep a close eye on it and give it a little nudge every 15 minutes or so.

I'm in windowed mode, but maximised. I'm on a laptop and the screen isn't huge, it's only 1366 x768

Share this post


Link to post
2 hours ago, JoshAtWar said:

Hey, I'm sorry for having a go at your script earlier. It's not like you're getting paid for this and it can't be nice writing and working on something for people to then just be as ungrateful as me! I had my reasons for being short tempered but knowing them will do you no good.

 

I have stuck with the script and what has really helped me is locking my screen on maximum zoom via the options -> controls screen. It still gets stuck though. The fire altar is almost perfect, almost never getting stuck, but the mind and air altars get stuck about 25% of the time- it's just because when the screen loads sometimes, the altar isn't in view. There's also sometimes a problem getting back out of the ruins  - sometimes the character walks away from the exit and if it does that, there's not much chance of it finding it's way back.

I think a good fix (though I'm not at all a programmer) would be to click ON the altar itself to move the character closer in between entering the ruins and crafting the runes. That way the altar is sure to be on screen. It might also work in reverse to fix the issue with it getting stuck on the way out of the ruins.

 

So far, I've used the script to craft over 5k runes and get my rc up 35 levels, so it can't be said that the script doesn't work, however, I've had to keep a close eye on it and give it a little nudge every 15 minutes or so.

I'm in windowed mode, but maximised. I'm on a laptop and the screen isn't huge, it's only 1366 x768

It's all good. No offence taken.

In fixed or windowed mode, the area the camera can view isn't as large as when it is in full screen.

I originally wrote the script in full screen mode so that was why you couldn't see the alter.

To fix this, I've changed the camera angle to go lower so that it can see father.

 

This should solve the problem for now but for best results I recommend running in non windowed mode as shown in the pictures in the original post.

I'll go through the script again and see if I can improve the exit alter by changing the areas and deal with rune essence.

Script should update within 30 minutes of this post.

 

If you have any additional problems, I'd be happy to help fix them.

Share this post


Link to post

Hi again :) Given how responsive and helpful you've been, is there any chance you can do something else for me? I'd really like a timer to be added so that I can stop it before 4 hours is up. 4 hours is a little excessive, you can make thousands of runes in that time haha. Or even if you can have randomised pauses/waits at the bank, that'd be cool.

Share this post


Link to post
10 hours ago, JoshAtWar said:

Hi again :) Given how responsive and helpful you've been, is there any chance you can do something else for me? I'd really like a timer to be added so that I can stop it before 4 hours is up. 4 hours is a little excessive, you can make thousands of runes in that time haha. Or even if you can have randomised pauses/waits at the bank, that'd be cool.

I can try to add one in the future

Might take some time since I'm working on some other projects right now

Is the script working alright for you now?

Share this post


Link to post

few days back the script worked, but i am getting this error now:

 

java.lang.NoClassDefFoundError: s/b 
    needscroll.FreeRunecrafter.FreeRunecrafter.<init>(FreeRunecrafter.java:26)
    org.powerbot.bot.ScriptController$ScriptBootstrap.run(ScriptController.java:154)

Share this post


Link to post
10 hours ago, daanie1234 said:

few days back the script worked, but i am getting this error now:

 

java.lang.NoClassDefFoundError: s/b 
    needscroll.FreeRunecrafter.FreeRunecrafter.<init>(FreeRunecrafter.java:26)
    org.powerbot.bot.ScriptController$ScriptBootstrap.run(ScriptController.java:154)

What rune are you crafting?

I am looking into the issue and running some tests but so far the script is running fine for me.

Is there a particular place where it breaks such as trying to enter the alter?

Share this post


Link to post
7 hours ago, needscroll said:

What rune are you crafting?

I am looking into the issue and running some tests but so far the script is running fine for me.

Is there a particular place where it breaks such as trying to enter the alter?

 

In does start, but the GUI of rune selecting is not popping up. I think I have some trouble with my java or something. I am running windows 10, 64 bit. I reinstalled java few days ago and it worked (had same error with some other scripts too). But the day after I opened rsbot again it didnt start the GUI (without a restart/reboot of pc).

Share this post


Link to post
14 hours ago, daanie1234 said:

 

In does start, but the GUI of rune selecting is not popping up. I think I have some trouble with my java or something. I am running windows 10, 64 bit. I reinstalled java few days ago and it worked (had same error with some other scripts too). But the day after I opened rsbot again it didnt start the GUI (without a restart/reboot of pc).

That's strange.

I don't know how I can fix the script for you since I am able to run the script without problems.

If you're having similar problems with other scripts I would suggest that it's a problem with your computer.

Try reinstalling java again?

 

Share this post


Link to post
2 minutes ago, needscroll said:

That's strange.

I don't know how I can fix the script for you since I am able to run the script without problems.

If you're having similar problems with other scripts I would suggest that it's a problem with your computer.

Try reinstalling java again?

 

I opened a conversation in the client forum, because I know its on my end. I will keep u posted if its working again. When the script worked it was flawless which was very nice! 

Share this post


Link to post
6 hours ago, daanie1234 said:

I opened a conversation in the client forum, because I know its on my end. I will keep u posted if its working again. When the script worked it was flawless which was very nice! 

Thank you.

I'm glad you like the script.

Share this post


Link to post
3 hours ago, fattyen said:

Hey this script just stopped working completely! I wont even start up any more

 

Fixed.

The problem was some weird error with the sdn but it should be good now.

Share this post


Link to post
gtj416   

Great script, running good. I had to switch all my rune ess to pure ess (not a big deal), but I have not had an issue yet! Only suggestion would be a xp counter and maybe a timer.

Edited by gtj416

Share this post


Link to post
15 hours ago, gtj416 said:

Great script, running good. I had to switch all my rune ess to pure ess (not a big deal), but I have not had an issue yet! Only suggestion would be a xp counter and maybe a timer.

Glad you enjoy it!

Exp counter and timer are currently in planning to be added.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now