Reminisce_

[OS] SStronghold Fighter

Recommended Posts

SStronghold Fighter is an OSRS combat script that trains for you at the Security Stronghold.

 

Features:

  • Supports Flesh Crawlers and Giant Spiders
  • Loots Items
  • Walks to Stronghold training location
  • Banks items and withdraws food from bank
  • Eats specified foods
  • Teleports back to Varrock when inventory is full or when you're out of food
  • Completes Stronghold questions
  • Dismisses random events
  • Closes 'Warning' message when climbing down Stronghold ladder(if you're too lazy to disable the pop-up)
  • Informative paint

Media:

31LyFfu.png

 

Proggies:

vowG1mg.png

NccY5hl.png

 

How to Get:

This script is available on the SDN

 

Note:

If you'd like to see another type of monster supported that is in the Security Stronghold please comment it below

 

The script only banks by teleporting to Varrock with runes or with a Teleport tab will add walking back to back in a future update.

 

Credits:

Chris - Walker and Stronghold door opening & question solver & Flesh crawler & Giant spider walk paths

Edited by Rias Grem0ry

Share this post


Link to post


While on the SDN hold (ctrl +f5) that should refresh the sdn for you.

the bot doesn't run to the bank after teleporting, you have to manually click to the bank. (grabs the tele tab and food) but then the bot doesnt run to the stronghold either. other than that great script and will help me out :D thank you

Share this post


Link to post
Chris   

the bot doesn't run to the bank after teleporting, you have to manually click to the bank. (grabs the tele tab and food) but then the bot doesnt run to the stronghold either. other than that great script and will help me out :D thank you

are you in fixed mode as resizable used to have issues walking

Share this post


Link to post

the bot doesn't run to the bank after teleporting, you have to manually click to the bank. (grabs the tele tab and food) but then the bot doesnt run to the stronghold either. other than that great script and will help me out :D thank you

As Chris has stated are you on fixed mode? Are you sure you selected teleport tab? I tested the script myself as you can see in the OP that proggie was with banking with tunes thought and it had banked twice. And I had tested it with a teleport tab earlier and it walked back perfectly fine.

Share this post


Link to post
pitxx   

the targeting system could use a little work, the bot sometimes clicks on another spider several times when you have one attacking you which makes you run around looking bot-like. Everything else is good travels from bank to stronghold and eats just fine

Share this post


Link to post
Chris   

the targeting system could use a little work, the bot sometimes clicks on another spider several times when you have one attacking you which makes you run around looking bot-like. Everything else is good travels from bank to stronghold and eats just fine

I think this happens sometimes when you eat and the bot thinks you're not in combat as you're not interacting so it looks for a new enemy

Share this post


Link to post

I think this happens sometimes when you eat and the bot thinks you're not in combat as you're not interacting so it looks for a new enemy

Yup that's why it happens. I will fix it in the next update.

Share this post


Link to post

Does it stall at the west bank for anyone else? Keeps switching from "Banking" to "Walking to Stronghold" any fix I can try?

Pushed version 0.1

  • Fixed bank stall glitch with runes teleportation

Share this post


Link to post

How do I get version 0.1? Excuse my ignorance, this is all new to me. I tried removing and adding, still stalls at the bank, which means I have old version.

It is already on the SDN. I just tested it and it doesn't stall anymore. Does it still happen for you?

Share this post


Link to post

It is already on the SDN. I just tested it and it doesn't stall anymore. Does it still happen for you?

as of Jan18, 17:25, yes, it still does it. I just stop it, walk away from the bank, and re-start it. That does the trick

Share this post


Link to post

as of Jan18, 17:25, yes, it still does it. I just stop it, walk away from the bank, and re-start it. That does the trick

Are you sure because I just updated the script about 30 minutes ago with the fix.

Share this post


Link to post

it doesnt eat for some odd reason? what is "food type" ? it asks for a number

 

edit: nevermind, now its eating?

 

edit edit: it stopped eating again... the food i am using is sharks

Edited by bottingpoints

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now